通达信公式如何画箱体,求,通达信多箱体公式

内容导航:
  • 求,通达信多箱体公式
  • 通达信软件指标箱体,源码如图,请教各位老师怎样修改那三个函数
  • 能不能把通达信箱体指标的画线用浅颜色 《虚线》 表示!
  • 求助把通达信箱体指标做成一个选股公式
  • 求通达信的股价突破长期箱体,再次回抽不跌破箱顶的选股公式
  • 求高手写一个突破箱体(震幅为20%的箱体)的通达信选股公式;要求:1、以涨停突破;2、以长上影突破;
  • Q1:求,通达信多箱体公式

    ((LOW+HIGH+CLOSE+O)/4,5),58),COLOR00AAFF;
    箱底:LLV(MA((LOW+HIGH+CLOSE+O)/4,6),88),COLORGREEN,LINETHICK2;
    VAR2:=EMA((HIGH+LOW+CLOSE)/3*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*20/10+箱底,2);
    VAR3:=(3*VAR2-2*SMA(VAR2,5,1))*0.3;
    VAR4:=(HHV(INDEXH,13)-INDEXC)/(HHV(INDEXH,13)-LLV(INDEXL,13));
    VAR5:=EMA(3*VAR4-2*SMA(VAR4,18,1),5);
    VAR6:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8));
    VAR7:=3*SMA(VAR6,3,1)-2*SMA(SMA(VAR6,3,1),5,1);
    VAR8:=(INDEXC*2+INDEXH+INDEXL)/4;
    VAR9:=EMA(VAR8,13)-EMA(VAR8,34);
    VARA:=EMA(VAR9,5);
    资金流向:=(VAR9-VARA+箱底)*1,COLORYELLOW;
    VARG1:=1.86*EMA(CLOSE,5)-EMA(CLOSE,13);
    趋势力度:VARG1,COLORFFAA99;
    K2:=BACKSET(趋势力度>REF(趋势力度,1),2);
    IF(K2,趋势力度,DRAWNULL),COLORFF00FF,LINETHICK1;
    AS:=箱底;
    牛气冲天:STICKLINE( 趋势力度>=AS,AS ,趋势力度 ,0,0 ) ,COLORRED ;
    STICKLINE( 趋势力度<= REF(趋势力度,1)
    AND 趋势力度>AS,AS ,趋势力度 ,0,1 ) ,COLORWHITE;
    趁机派发:STICKLINE( REF(趋势力度,2)<REF(趋势力度,1) AND 趋势力度<= REF(趋势力度,1)
    AND 趋势力度>AS,AS ,趋势力度 ,0 ,0 ) ,COLORGREEN ;
    熊气盖天:STICKLINE( 趋势力度<AS-0.5,AS-0.5 ,趋势力度 ,0 ,1 ) , ;
    MA3:MA(C,3),COLORAAEE00;
    MA21:MA(C,21),COLORGREEN;
    MA151:MA(C,151),COLOR0000CF;
    K1:=BACKSET(MA21>REF(MA21,1),2);
    {股旁网-股票公式网站 www.GUpang.com}
    强A:IF(K1,MA21,DRAWNULL),COLOR0000FF,LINETHICK2;
    {DRAWTEXT( CROSS(MA3 , 箱底),L*0.99 , '试'),COLORRED;}
    DRAWTEXT( CROSS(MA3 , MA21),L , '买'),COLORYELLOW;
    DRAWTEXT( CROSS(MA3 , 箱顶) AND C>箱顶,箱顶 , '追'),COLOR00EEAA;
    DRAWTEXT( CROSS(箱顶,MA3)AND C<箱顶 ,H , '卖') ,COLORFFAA99;
    DRAWTEXT( REF(资金流向 ,2)<REF(资金流向 ,1) AND REF(资金流向 ,1)>资金流向
    AND 资金流向>箱顶 AND C>箱顶,H*1.02, '顶'),COLORWHITE;
    DRAWTEXT( CROSS(趋势力度 , 箱底),箱底, '加仓'),COLORRED;
    E1:=BARSCOUNT(C);
    AH:=HHV(H,200);
    AL:=LLV(L,200);
    B0:=(AH-AL)/40;
    KB1:=H+B0;
    KB2:=L-B0;
    STICKLINE((E1+0)/34=FLOOR((E1+0)/34),KB2,KB2-3*B0,1,0),COLORYELLOW,LINETHICK2;
    DRAWTEXT((E1+0)/34=FLOOR((E1+0)/34),KB2-2*B0,'时间窗'),COLORWHITE;

    Q2:通达信软件指标箱体,源码如图,请教各位老师怎样修改那三个函数

    这个指标是通达信的,但是不知道你要修改成那个软件的公式呢?看你图片中的那公式编辑器,他不是通达信的,自然无法测试通过的,如果是通达信,是可以的,请看下面的图片

    股理乾坤为您解答

    源码如下

    箱顶:PEAK(C,N,1)*0.98;

    箱底1:TROUGH(C,N,1)*1.02;

    箱高:100*(箱顶-箱底1)/箱底1,NODRAW;

    Q3:能不能把通达信箱体指标的画线用浅颜色 《虚线》 表示!

    朋友,你需要改写的箱体技术指标如下。公式已在通达信华彩人生版调试通过。请参考附图。

    祝您投资成功!

    【箱顶】:PEAK(CLOSE,N,1)*0.98,,POINTDOT;

    【箱底】:TROUGH(CLOSE,N,1)*1.02,POINTDOT;

    【箱高】:100*(【箱顶】-【箱底】)/【箱底】,NODRAW;

    Q4:求助把通达信箱体指标做成一个选股公式

    【箱顶】:PEAK(CLOSE,N,1)*0.98;

    【箱底】:TROUGH(CLOSE,N,1)*1.02;

    【箱高】:100*(【箱顶】-【箱底】)/【箱底】,NODRAW;

    没有选股条件,如何做。

    Q5:求通达信的股价突破长期箱体,再次回抽不跌破箱顶的选股公式

    比较接近的答案是:
    顶:=REF(HHV(H,30),1);
    放量突破:=DYNAINFO(7)>顶 AND VOL>REF(HHV(VOL,30),1);
    B:=BARSLAST(CROSS(顶,C)=0;
    A:=BARSLAST(放量突破);
    XG:(放量突破 OR A>0 )AND B;

    Q6:求高手写一个突破箱体(震幅为20%的箱体)的通达信选股公式;要求:1、以涨停突破;2、以长上影突破;

    其实没有那么复杂,你可以把你的数据下全,用区间统计,就可以了 我DATE=20101215-19000000); P2:=BARSLAST(DATE=20110123-19000000); P3:=P

    上一篇:上一篇:今日股市王斌下载
    下一篇:下一篇:高考结束什么股票
    • 评论列表

    发表评论: